php

Доступны корректирующие выпуски языка программирования PHP 7.0.3, 5.6.18 и 5.5.32, в которых внесено около 40 изменений, в том числе устранено несколько уязвимостей: несколько проблем, связанных с разыменованием указателя NULL, возможность фальсификации вывода функции stream_get_meta_data, целочисленное переполнение в iptcembed(), обращение к неинициализированной области памяти в openssl_seal(), повреждение памяти при разборе некорректных файлов tar/zip/phar, переполнение стека при распаковке файлов tar, обращение к уже освобождённым областям памяти в SPL, переполнение буфера в вызове exec() и т.п.

В версиях PHP 5.6.18 и 7.0.3 также добавлена поддержка нового кода ответа HTTP 451 (Unavailable For Legal Reasons), предназначенного для обозначения факта блокировки доступа на основании решения властей. Библиотека pcrelib обновлена до версии 8.38.

 

 Оставить комментарий

(обязательно)

(обязательно)

   
Copyright © 2012. Linuxguru.ru